Mingle's official browser support policy

Posted by Ethan

25 November 2014

We’ve received feedback that our last post about browser support wasn’t exactly clear. Hopefully, this fixes that!

We support the latest stable versions of:


As we know, Internet Explorer is a different beast :)

At the time of this post, we support IE 10 and IE 11. Moving forward, we will try our best to give at least 3 months notice if we intend to drop support for a version(s) of IE.

Please follow us @thatsmingle for news, or drop a note to us at support@thoughtworks.com if you encounter any issues using Mingle with any of our supported browsers.

comments powered by Disqus